Problem doesn't occur under udb

  • 15 December 2021
  • 1 reply

Hi. I am working on a complex open-source project and I have a bug that occurs in about 2/3 of runs. There are at least 3 ways the problem expresses: segfault, map access out-of-range and another less common way. (So it could be more than one bug.) When the bug occurs there are usually 15-20 interacting threads running, some of which are state-machines.

The problem is that when I run it under udb the problem never occurs. I’ve tried nearly 100 times.

I’m looking for ideas to make the bug occur or at least increase the likelihood that the bug will occur under udb. Ideas? Any help is greatly appreciated!


Best answer by gel 15 December 2021, 20:59

View original

1 reply

Our LiveRecorder product has a feature called Thread-Fuzzing which may be of help here. Basically it makes race conditions more likely to appear under recording. That feature is not available in UDB. If you’d be interested in that I can you an eval copy of LiveRecorder - probably easiest to email me at greg @ <our company domain> and I’ll get that sorted for you.